Phone Service Interruption
Incident Report for BuildingLink
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 12:45 EDT
Investigating
The phone service that we use to make and answer phone calls is currently experiencing an issue. We will be working with this service to try and find a resolution as quickly as possible. In the meantime, please feel free to email us at support@BuildingLink.com and we will be happy to assist.

Le service téléphonique que nous utilisons pour passer et répondre aux appels téléphoniques rencontre actuellement un problème. Nous travaillerons avec ce service pour essayer de trouver une solution aussi rapidement que possible. En attendant, n'hésitez pas à nous envoyer un e-mail à support@BuildingLink.com et nous serons heureux de vous aider.

El servicio telefónico que utilizamos para hacer y contestar llamadas telefónicas está experimentando actualmente un problema. Estaremos trabajando con este servicio para tratar de encontrar una solución lo más rápido posible. Mientras tanto, no dude en enviarnos un correo electrónico a support@BuildingLink.com y estaremos encantados de ayudarle.
Posted Apr 22, 2024 - 11:11 EDT