Display Issues with some Modules

Incident Report for BuildingLink

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 10:17 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Logging out and logging back in to BuildingLink should resolve issues related to this Incident.
Posted Oct 19, 2025 - 16:01 EDT

Update

We have identified the issue and are currently working to reach a solution.
Posted Oct 19, 2025 - 15:33 EDT

Identified

We are currently investigating an issue with some modules where items are failing to display properly. We will update as soon as we have some updated information.
Posted Oct 19, 2025 - 15:21 EDT
This incident affected: Services (Email, KeyLink, TimeTracker, ConciergeLink), Apps (Geo, Resident, Valet), and Sites (Management Portal, Resident Portal, Help Site, Public Display).