Partial Site Outage
Incident Report for BuildingLink
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 11:37 EST
Identified
We have received some reports of intermittent site performance issues. We are investigating this problem.
Posted Nov 10, 2020 - 10:53 EST
This incident affected: Sites (Management Portal, Resident Portal).